#1 Global Leader in Data Protection & Ransomware Recovery

Removing Stuck VMDK From the Veeam Proxy

KB ID: 1775
Product: Veeam Backup & Replication
Published: 2013-06-20
Last Modified: 2023-09-13
Languages: IT | ES
mailbox
Get weekly article updates
By subscribing, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.

Cheers for trusting us with the spot in your mailbox!

Now you’re less likely to miss what’s been brewing in our knowledge base with this weekly digest

error icon

Oops! Something went wrong.

Please try again later.

Challenge

A VM that Veeam processed is found to require consolidation, yet consolidation attempts fail.

or

A VM that Veeam processed is found to have an orphaned snapshot.

 

Cause

This may occur when Virtual Appliance Mode (HOTADD) is used to back up a VM and is caused by:

  • VMware does not process the command to release the virtual machine's disk from the proxy.
  • The Veeam server crashes while processing a virtual machine.
  • Jobs running within Veeam were forced to stop, and those jobs were using Virtual Appliance Mode (HOTADD).
  • A backup or replication job creates a snapshot on the backup proxy while another job is using the proxy.
    Note: It is advised to build dedicated VMware Backup Proxies and not back them up or replicate them.

Solution

Before You Begin

Ensure that all jobs have stopped. This will ensure that the only disks that will be found attached to proxies will be the proxy's own disks and the ones that need to be removed.

 

Identify Problem VMs

  1. Using a vSphere Client, find any virtual machines displaying a warning that consolidation is needed.

     
  2. Perform consolidation and note which virtual machines continue to have a warning regarding consolidation.




     

Find Stuck HOTADDed Disks

Review the settings of each Veeam Proxy, looking for any disks that match the following:

  • The name of VMDK does not match the proxy and matches a VM identified in the previous section.
  • The disk has a Disk Mode of [Independent - NonPersistent]
    Note: If the proxy is used as a Target Proxy for replication, the replica disks will be attached as Dependant.


     

Release Stuck HOTADDed Disks

Once you have found a disk HOTADDed to a proxy that needs to be released, perform the following steps to release it.

  1. Click the symbol to select the disk for removal.

    Note: Do not check the box to delete files from datastore!
  2. Click [OK] to Confirm the removal.
  3. After the disk is released from the proxy, attempt Consolidation again.

More Information

If you find that a specific proxy continues have issues with disks becoming stuck HOTADDed to it, please review: https://www.veeam.com/kb1882

For more information regarding orphaned snapshots, please read https://kb.vmware.com/s/article/1005049.
To submit feedback regarding this article, please click this link: Send Article Feedback
To report a typo on this page, highlight the typo with your mouse and press CTRL + Enter.

Spelling error in text

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

Oops! Something went wrong.

Please try again later.

You have selected too large block!

Please try select less.

KB Feedback/Suggestion

This form is only for KB Feedback/Suggestions, if you need help with the software open a support case

By submitting, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Verify your email to continue your product download
We've sent a verification code to:
  • Incorrect verification code. Please try again.
An email with a verification code was just sent to
Didn't receive the code? Click to resend in sec
Didn't receive the code? Click to resend
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

error icon

Oops! Something went wrong.

Please try again later.