https://login.veeam.com/en/oauth?client_id=nXojRrypJ8&redirect_uri=https%3A%2F%2Fwww.veeam.com%2Fservices%2Fauthentication%2Fredirect_url&response_type=code&scope=profile&state=eyJmaW5hbFJlZGlyZWN0TG9jYXRpb24iOiJodHRwczovL3d3dy52ZWVhbS5jb20vYXZhaWxhYmlsaXR5LWNvbnNvbGUtc3VwcG9ydGVkLWVudmlyb25tZW50cy5odG1sIiwiaGFzaCI6ImIxMjljMGYzLTlhMDQtNGY3ZC1iNjI5LTRkMTA1NDI1MmIyMyJ9
1-800-691-1991 | 9am - 8pm ET
EN

System requirements 

Unless otherwise stated, all third party software must be at the latest update and/or patch level.

Veeam Service Provider Console

The machine where you want to install Veeam® Service Provider Console must meet the following requirements:

Hardware

  • CPU: modern x64 processor (minimum 4 cores) 
  • Memory: 4 GB RAM (minimum), 8 GB RAM (recommended)

Software

  • Microsoft SQL Server 2019/2017/2016/2014/2012 (SQL Server Express 2012 SP4 and SQL Server Express 2016 SP2 are included in the setup)
  • Microsoft SQL Server 2012 Native Client (included in the setup)
  • Microsoft SQL Server 2014 System CLR Types (included in the setup)
  • Microsoft .NET Framework 4.7.2 (included in the setup)
  • Microsoft Internet Information Services (IIS) 7.0 or later
  • Windows Installer 5.0
  • Microsoft PowerShell 5.0 or later
  • Microsoft Edge (latest version), Mozilla Firefox (latest version), Google Chrome (latest version)
  • Microsoft Report Viewer 2015 (included in the setup)
  • PDF viewer for viewing reports

OS
Only 64-bit version of the following operating system is supported:

  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016 
  • Microsoft Windows Server 2012 R2 
  • Microsoft Windows Server 2012 
  • Microsoft Windows Server 2008 R2 SP1 
  • Microsoft Windows Server 2008 SP2 
  • Microsoft Windows 10 (version 1803 or later)
  • Microsoft Windows 8.x
  • Microsoft Windows 7 SP1

Note: You cannot install Veeam Service Provider Console on a machine running Microsoft Windows Server Core.

Veeam Cloud Connect

Veeam Service Provider Console integrates with Veeam Cloud Connect and requires the following components be deployed in the backup infrastructure:

Platforms

  • Veeam Backup & Replication™
  • VMware Cloud Director

Software

  • Microsoft PowerShell 5.0 or later

Infrastructure

  • Veeam Backup & Replication v11 (recommended)
  • Veeam Backup & Replication v10 or later build (compatible)
  • Veeam Backup & Replication 9.5 Update 4 or later build (compatible)
  • VMware Cloud Director 10.x (up to 10.2)
  • VMware Cloud Director 9.7
  • VMware Cloud Director 9.5

Plug-ins

Platforms

  • ConnectWise Automate
  • ConnectWise Manage
  • Grafana

Infrastructure

  • ConnectWise Automate 20 or later
  • ConnectWise Manage 2020.1 or later
  • Grafana 6.5 or later

Management Agents

Machines running Veeam Service Provider Console management agents must meet the following requirements:

Hardware

  • CPU: x86-64 processor architecture
  • Memory: 2 GB RAM

Windows OS
Both 64-bit and 32-bit (where applicable) versions of the following operating systems are supported except Server Core installations for server OS:

  • Microsoft Windows Server 2019 
  • Microsoft Windows Server 2016 
  • Microsoft Windows Server 2012 R2 
  • Microsoft Windows Server 2012 
  • Microsoft Windows Server 2008 R2 SP1 
  • Microsoft Windows 10 
  • Microsoft Windows 8.x 
  • Microsoft Windows 7 SP1 

Software

  • Microsoft .NET Framework 4.6 or later (Windows computers)

Hardware

  • CPU: x86-64 processor architecture
  • Memory: 2 GB RAM

Linux OS

  • Linux kernel 2.6.32–5.7.7.

Both 64-bit and 32-bit (where applicable) versions of the following operating systems are supported:

  • Debian 9.0–10.5
  • Ubuntu 14.04, 16.04, 18.04, 20.04*, 20.10*
  • RHEL 6.0–8.3
  • CentOS 6.0–8.3
  • Oracle Linux 6–8.3
  • Oracle Linux 6 (starting from UEK R1)–Oracle Linux 8.3 (up to UEK R6)
  • SLES 12 SP2–15 SP2
  • SLES for SAP 12 SP2–15 SP2
  • Fedora 32
  • openSUSE Leap 15.2
  • openSUSE Tumbleweed

1 As long as you use kernels supplied by your distribution; Consider the following limitations:

  • Fedora is supported up to kernel 5.7.7, inclusive.
  • openSUSE Tumbleweed is supported up to kernel 5.7.7, inclusive.
  • Linux kernel 2.6.32-754.6.3 in CentOS / RHEL and Oracle Linux (RHCK) is not supported.
  • Ubuntu 20.04 and 20.10 with kernel version 5.8 or later support file-level backup mode only.

Hardware

  • Intel-based CPUs
  • ARM-based CPUs (experimental support via Rosetta emulator)

macOS

  • version 10.13 or later (macOS 10.13 High Sierra macOS 11 Big Sur)

Network

  • 32 kbit/s when managing Veeam Agent for Microsoft Windows
  • 32 kbit/s when managing Veeam Agent for Linux
  • 32 kbit/s when managing Veeam Agent for Mac
  • 64 kbit/s when managing Veeam Backup & Replication

Managed computers

Veeam Service Provider Console can manage the following Veeam products:

Platforms

  • Veeam Agent for Microsoft Windows 5.0
  • Veeam Agent for Microsoft Windows 4.0 (compatible)
  • Veeam Agent for Linux 5.0
  • Veeam Agent for Mac 1.0
  • Veeam Backup & Replication v11
  • Veeam Backup & Replication 10.x
  • Veeam Backup & Replication 9.5 Update 4 or later (compatible)
  • Veeam Backup for AWS 3.0 (compatible) via Veeam Backup & Replication plug-in
  • Veeam Backup for AWS 2.0 via Veeam Backup & Replication plug-in
  • Veeam Backup for Microsoft Azure 2.0 via Veeam Backup & Replication plug-in

Network

For remote network discovery rules based on the IP range option, discovered computers must have the following firewall rules enabled:

  • File and Printer Sharing (SMB-In), TCP port 445.
  • Windows Management Instrumentation (WMI-In).
  • Remote Scheduled Tasks Management (RPC and RPC-EPMAP). Incoming. TCP, RPC Dynamic Ports firewall rule.
  • TCP port 6180 (required for establishing the connection with cloud gateways).
  • TCP port 22 (required for establishing the SSH connection with computers running Linux OS)

Software

  • Veeam Management Agent