https://login.veeam.com/en/oauth?client_id=nXojRrypJ8&redirect_uri=https%3A%2F%2Fwww.veeam.com%2Fservices%2Fauthentication%2Fredirect_url&response_type=code&scope=profile&state=eyJmaW5hbFJlZGlyZWN0TG9jYXRpb24iOiJodHRwczovL3d3dy52ZWVhbS5jb20va2IyMTQ1IiwiaGFzaCI6IjU1M2FmMjc2LTc3ZDItNDkzYy05ZTQ3LWU2YTAzYmNkYjZhZiJ9
1-800-691-1991 | 9am - 8pm ET
EN

Error Backup Repository ‘Repository ID #’ was not found

Challenge

Running a Veeam Endpoint Backup (VEP) of Veeam Agent for Windows (VAW) backup job to a repository in Veeam Backup & Replication returns the following error:
Error Backup repository ‘ID Number’ was not found (System.Exception)

Cause

Veeam Backup & Replication is providing an incorrect repository ID due to VEP/VAW backups being imported in.

Solution

Check the Veeam Backup & Replication GUI under 'Backup & Replication' view, and verify if the backup job shows under disk imported. If it does, remove the backups from configuration. Then re-run VEP/VAW backup to check how it works.
KB ID:
2145
Product:
Veeam Agent for Microsoft Windows
Version:
1.x, 2.x
Published:
2016-07-27
Last Modified:
2020-08-13
Please rate how helpful this article was to you:
5 out of 5 based on 1 ratings
Thank you for helping us improve!
An error occurred during voting. Please try again later.

Couldn't find what you were looking for?

Below you can submit an idea for a new knowledge base article.
Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Spelling error in text

Knowledge base content request
By submitting, you agree that your personal data will be managed by Veeam in accordance with the Privacy Policy.
Your report was sent to the responsible team. Our representative will contact you by email you provided.
We're working on it please try again later