How to disable TLS 1.0 with no impact on Veeam ONE functionality

KB ID: 2697
Product: Veeam ONE
Version: 9.5
Published:
Last Modified: 2018-07-31

Challenge

There are several issues could occur after disabling TLS 1.0 protocol on the Veeam ONE server:

  1. Veeam ONE 9.5 server may lose a connection to the SQL Server for runtime operations
  2. Veeam ONE 9.5 server may lose a connection to the SQL Server during the initial installation
  3. “Veeam Licensing” web server is unavailable when only TLS 1.2 protocol is enabled
  4. Veeam ONE Reporter website doesn’t work when only TLS 1.2 protocol is enabled

Cause

TLS 1.0 is no longer officially supported.

Solution

1. Veeam ONE server may lose a connection to the SQL Server for runtime operations
Solution: install an updated SQL Server Native Client (11.0) to the Veeam ONE server machine

2. Veeam ONE server may lose a connection to the SQL Server during the initial installation
Solution: use https://www.veeam.com/KB2265

3. “Veeam Licensing” web server is unavailable when only TLS 1.2 protocol is enabled
Solution: enable TLS 1.1

4. Veeam ONE Reporter website doesn’t work when only TLS 1.2 protocol is enabled
Solution: enable TLS 1.1 or explicitly activate “DES” cipher support on the Veeam ONE server machine
 

More Information

Should you have any questions, contact Veeam Support.

Please be aware that we’re making changes which will restrict access to product updates for users without an active contract.

OK

Rate the quality of this KB article: 
5 out of 5 based on 1 ratings

Couldn't find what you were looking for?

Below you can submit an idea for a new knowledge base article.

Request new content