VEEAM ENDPOINT BACKUP 1.0.2 FOR LABTECH

Release Notes

The Release Notes document provides last-minute information about Veeam Endpoint Backup for LabTech, including relevant information on technical support, documentation, online resources, etc.

Veeam Endpoint Backup for LabTech allows:

- Remote deployment and management of backups across numerous endpoints
- Remote bare-metal restores of failed computers from the LabTech console
- Monitoring and reporting of endpoint backups from the LabTech console
- Back up files, disk volumes or entire endpoints
- Integration with LabTech Backup Manager and more!

The current version of Veeam Endpoint Backup for LabTech is available from September 7, 2016.

See next:

- Known Issues and Limitations
- System Requirements
- Permissions
- Licensing
- Installing Veeam Endpoint Backup for LabTech
- Upgrading Veeam Endpoint Backup for LabTech
- Contacting Veeam Software
Known Issues and Limitations

This section lists issues known in Veeam Endpoint Backup for LabTech.

**General**

- Veeam Endpoint Backup switches to the full access UI mode after triggering the upgrade script from LabTech Control Center.

- ‘Latest Backup Job’ state widget on the ‘Veeam Endpoint Backup Overview’ tab does not display the ‘running’ state for backup jobs launched from the plug-in.

- To install Veeam Endpoint Backup for LabTech, ‘LabTech Database Agent’ and ‘LabTech MySQL Server’ services must be up and running.

- The ‘Discovered Endpoints’ dataview displays all Veeam Endpoint Backup FREE installations as activated after LabTech agent or Veeam Endpoint Backup for LabTech re-installation. To resolve this, run the activation script against these endpoints via LabTech Control Center.

- The ‘Activate Veeam Endpoint Backup’ script needs to be re-triggered for all activated endpoints after re-installing LabTech agent or Veeam Endpoint Backup for LabTech.

- “Install Veeam Endpoint Backup” and “Update Veeam Endpoint Backup” scripts fail, if target computer needs to be restarted. To complete installation or upgrade of Veeam Endpoint Backup, reboot target computer and re-launch the script.

- Predefined scripts might not be displayed after installing the plug-in. To resolve that, update system cache via Tools option: ‘Reload System Cache’.

- Under certain circumstances, the ‘Enable Read-only mode for Veeam Endpoint Backup’ script does not set read-only UI access mode to Veeam Endpoint Backup. To resolve that, re-trigger this script again.

- License key cannot be revoked for an offline endpoint.

- Veeam Endpoint Backup job settings and configuration changes are not synchronized back to Veeam Endpoint Backup for LabTech if these changes are done in Veeam Endpoint Backup manually by a user.

- Predefined monitors are still triggered when Veeam Endpoint Backup for LabTech gets disabled in the Plugin Manager UI.

- After changing the destination target for the backup job, the available restore points counter is reset.

- Any user opening the LabTech Control Center UI should have read/write access to the ‘C:\Program Files (x86)\LabTech Client’ folder.

- When launching Veeam Endpoint Backup dataviews from the Client or Location tabs, the scope filtering will be ignored and dataviews will display information about all endpoints to which LabTech admin has access to in the Control Center.

- When re-installing LabTech agent on a managed computer running Veeam Endpoint Backup, this computer will be accounted twice in Veeam licenske key usage. To resolve that, please revoke the license key from one of the computers.
Uninstall

- Under rare conditions reports list, dataviews, monitors are not removed in the LabTech server after uninstall process. To resolve that, update system cache via Tools option: ‘Reload System Cache’.

- Before uninstalling Veeam Endpoint Backup for LabTech, all Veeam Endpoint Backups running in read-only access UI mode should be switched to the full access mode via script.
System Requirements

To install and use Veeam Endpoint Backup for LabTech, make sure that your LabTech RMM environment meets the necessary system requirements.

LabTech Server

The machine where you want to install Veeam Endpoint Backup for LabTech must meet the following requirements:

<table>
<thead>
<tr>
<th>Specification</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>LabTech RMM</td>
<td>• LabTech 10.5</td>
</tr>
<tr>
<td></td>
<td>• LabTech 11</td>
</tr>
<tr>
<td>OS</td>
<td>Only 64-bit versions of the following operating systems are supported:</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2012 R2</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2012</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 R2 SP1</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 SP2</td>
</tr>
<tr>
<td>Software</td>
<td>• LabTech Server (for software and hardware requirements, refer to LabTech Installation Prerequisites).</td>
</tr>
<tr>
<td></td>
<td>• Microsoft .NET Framework 4 or later</td>
</tr>
<tr>
<td></td>
<td>• Microsoft PowerShell 2.0 or later</td>
</tr>
<tr>
<td>Network</td>
<td>To ensure that Veeam Endpoint Backup for LabTech can update the license and send license usage statistics to the Veeam licensing server, check that:</td>
</tr>
<tr>
<td></td>
<td>• The LabTech server is connected to Internet.</td>
</tr>
<tr>
<td></td>
<td>• The firewall on the LabTech server allows inbound and outbound HTTPS traffic over port 443.</td>
</tr>
<tr>
<td></td>
<td>• If you connect to the Internet through a proxy server, make sure that winhttp proxy settings are properly configured on the LabTech server.</td>
</tr>
</tbody>
</table>

Managed Computers

Every managed computers must meet the following requirements:

<table>
<thead>
<tr>
<th>Specification</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS</td>
<td>All Windows OSes supported by Veeam Endpoint Backup. For details, see Veeam Endpoint Backup System Requirements.</td>
</tr>
<tr>
<td>Software</td>
<td>• Microsoft .NET Framework 4.5.2 or later.</td>
</tr>
<tr>
<td></td>
<td>• Labtech Agent. For software and hardware requirements to machines running LabTech agents, refer to LabTech Agent Deployment Requirements.</td>
</tr>
<tr>
<td>Network</td>
<td>Internet connection is required to download Veeam Endpoint Backup installation files and updates from Veeam Software.</td>
</tr>
</tbody>
</table>
Veeam Endpoint Backup

Veeam Endpoint Backup v 1.1.1 or later is supported.

Backup Manager Plug-in

Veeam Endpoint Backup for LabTech integrates with LabTech Backup Manager to help you quickly identify issues with backup jobs.

For details on Backup Manager installation and configuration, refer to LabTech Backup Manager documentation.

Permissions

To access the Veeam Endpoint Backup data in the LabTech Control Center, a user must have **Read** permissions for **Templates**, **Clients**, **Reports**, **Users** and **Scripts**.

All Veeam Endpoint Backup for LabTech objects, such as dashboards, dataviews, reports, alerts and tickets, will be limited to the clients and groups to which the user has access.

Licensing

Veeam Endpoint Backup for LabTech license is required for each managed computer. A managed computer is a machine running Veeam Endpoint Backup that is administered from the LabTech Control Center (or otherwise, Veeam Endpoint Backup that has been activated).

The license distinguishes two types of managed computers — desktops and servers.

- Managed desktops run desktop versions of supported OSes.
- Managed servers run server versions of supported OSes.

One license can cover any number of managed desktops and/or servers.
Installing Veeam Endpoint Backup for LabTech

To install Veeam Endpoint Backup for LabTech:
1. Check prerequisites.
2. Deploy LabTech agents on endpoints.
3. Install Veeam Endpoint Backup for LabTech.
4. Install the Veeam Endpoint Backup for LabTech license.

Before You Begin

Before you install Veeam Endpoint Backup for LabTech:

- Make sure that the managed environment meets the necessary requirements. For details, see System Requirements.
- On the workstation with the LabTech Control Center, check whether the L: drive is mapped to the LTShare on the LabTech server. If the drive is not mapped to the LTShare, Veeam reports will not be installed.

By default, the L: drive is automatically mapped to the LTShare when the LabTech server is installed. If the drive is not mapped, you must map it manually.

Step 1. Deploy LabTech Agents

Deploy LabTech agents on all endpoints that will run Veeam Endpoint Backup, and that are designated as targets for monitoring and reporting with the LabTech RMM and Veeam Endpoint Backup for LabTech.

For information on requirements to agent-enabled machines and deployment methods, see LabTech Agent Deployment Documentation.

Step 2. Install Veeam Endpoint Backup for LabTech

To install Veeam Endpoint Backup for LabTech:
1. Open the LabTech Control Center.
2. From the Control Center menu, choose Tools > Solution Center.
3. In the Solution Center, search for the Veeam Endpoint Backup solution.
4. Click the Veeam Endpoint Backup solution and click Queue.
5. In the Terms of Service window, click Yes.
6. Click Solutions in Queue at the top of the navigation sidebar.
7. In the Queued Solutions section, click Install/Update.
8. In the Install/Update Notice window, choose whether you want to back up the local database before upgrade and click Yes.
9. After installation completes, click Finished and close the Solution Center.
10. From the Control Center menu, choose Help > Plugin Manager.
11. In the list of available plug-ins, select Veeam Endpoint Backup for LabTech and click Enable.
12. Restart the LabTech database agent.
   • [For LabTech 11] You will be prompted to reload the database agent after you enable the plug-in. In the Restart Database Agent dialog box, click Yes.
   • [For LabTech 10.5] Click Advanced, select Reload Plugins > Reload DBAgent Plugins. In the displayed dialog box, click Yes.
     Wait for LabTech to restart the database agent.
13. Restart the Control Center. The install process may take from one to several minutes to complete.

**Step 3. Install the License**

To manage Veeam Endpoint Backup from the LabTech Control Center, you must install Veeam Endpoint Backup for LabTech license:

1. On the LabTech Control Center toolbar, click Dashboard.
   Alternatively, choose Main > Dashboard in the Control Center menu.
2. In the System Dashboard window, open Config > Integration > Veeam Endpoint Backup for LabTech.
3. In the License section, click Install and choose the Veeam Endpoint Backup for LabTech license file.
4. In the displayed dialog box, click OK.
5. Select the Update and report on license usage automatically check box if the Veeam Endpoint Backup for LabTech must periodically send license usage statistics to the Veeam licensing server and perform automatic license update.
   If this check box is not selected, you will need to send license usage statistics manually.
Upgrading Veeam Endpoint Backup for LabTech

Upgrade to Veeam Endpoint Backup for LabTech 1.0.2 is supported from version 1.0.1.117.

To upgrade Veeam Endpoint Backup for LabTech:

1. Open the LabTech Control Center.
2. From the Control Center menu, choose Tools > Solution Center.
3. In the Solution Center, search for the Veeam Endpoint Backup solution.
4. Click the Veeam Endpoint Backup solution and click Queue.
5. In the Terms of Service window, click Yes.
6. At the top of the navigation sidebar, click Solutions in Queue.
7. In the Queued Solutions section, click Install/Update.
8. In the Install/Update Notice window, choose whether you want to back up the local database before upgrade and click Yes.
9. After upgrade completes, click Finished and close the Solution Center.
10. From the Control Center menu, choose Help > Plugin Manager.
11. In the list of available plug-ins, select Veeam Endpoint Backup for LabTech and click Enable.
12. Restart the LabTech database agent.
   • [For LabTech 11] You will be prompted to reload the database agent after you enable the plug-in. In the Restart Database Agent dialog box, click Yes.
   • [For LabTech 10.5] Click Advanced, select Reload Plugins > Reload DBAgent Plugins. In the displayed dialog box, click Yes.
      Wait for LabTech to restart the database agent.
13. Restart the Control Center. The upgrade process may take from one to several minutes to complete.
14. Clear the LabTech system cache. To do this, from the Control Center menu, choose Tools > Reload System Cache.
15. After upgrade, run data collection against all managed computers running Veeam Endpoint Backup.
Contacting Veeam Software

At Veeam Software we value the feedback from our customers. It is important not only to help you quickly with your technical issues, but it is our mission to listen to your input, and build products that incorporate your suggestions.

Customer Support

Should you have a product issue, suggestion or question, please visit our Customer Center Portal at cp.veeam.com to open a case, search our knowledge base, reference documentation, manage your license or obtain the latest product release.

Online Support

If you have any questions about Veeam solutions, you can use the following resources:

- Full documentation set at www.veeam.com/documentation-guides-datasheets.html
- Community forum: forums.veeam.com

Company Contacts

For the most up to date information about company contacts and offices location, please visit www.veeam.com/contacts.html.