Release Notes

The Release Notes document provides last-minute information about Veeam Backup & Replication plug-in for LabTech (Veeam Backup & Replication Plug-in), including relevant information on technical support, documentation, online resources, etc.

The Veeam Backup & Replication Plug-in allows you to monitor key aspects of Veeam Backup & Replication infrastructure and operations in LabTech Control Center. With the Veeam Backup & Replication Plug-in installed, you can:

- Audit the state and performance of Veeam backup infrastructure components
- Analyze VM data protection efficiency for managed clients and locations and ensure that mission-critical VMs have valid backup and replica restore points
- Monitor and manage Veeam Backup & Replication jobs on remote backup servers
- Receive alerts and tickets about critical situations around the backup infrastructure components and data protection operations
- Generate reports based on data collected from Veeam backup servers and protected VMs

The current version of Veeam Backup & Replication Plug-in is available from August 3rd, 2016.

See next:

- Known Issues and Limitations
- Prerequisites
- System Requirements
- Permissions
- Licensing
- Installing the Veeam Backup & Replication Plug-in
- Upgrading the Veeam Backup & Replication Plug-in
- Uninstalling the Veeam Backup & Replication Plug-in
- Contacting Veeam Software
**Known Issues and Limitations**

This section lists issues known in Veeam Backup & Replication Plug-in.

**General**

- Installing Veeam Backup & Replication plug-in to LabTech server with non-default collation of MySQL database is not supported.
- If Veeam Backup Enterprise Manager is used, Veeam backup server should be added to both LabTech server and Veeam Backup Enterprise Manager using the same DNS name.
- LabTech Database Agent service should be running when Veeam Backup & Replication plug-in is installed.
- LabTech agent installed on the managed Veeam Backup & Replication server should have sufficient permission to Veeam Backup & Replication database in order to use backup job management tasks from LabTech Control Center.
- Predefined dataviews (Protected VMs, Jobs, Events, License Information) always display information collected from all discovered Veeam Backup & Replication servers.
- If “Veeam: Collect Backup Server Data” collection script is triggered when “Computer Window” in LabTech Control Center is opened, backup data will be missing. To resolve that, reopen “Computer Window” of the Veeam Backup & Replication server.
- “Veeam Backup Jobs” and “Veeam Backup Infrastructure” tabs do not display information about Veeam Backup & Replication servers that are managed by Veeam Backup Enterprise Manager and belong to different clients.
- Server column for CIFS repositories does not have any data in “Veeam Backup Infrastructure” widget.
- “Latest Backup Job Status”, “VM Backup Status” and LabTech Backup Manager do not display any data if backup job didn’t have any successful runs.

**LabTech Backup Manager Integration**

- Job Fails (in last 7 days) counter does not filter failed job retries.

**Upgrade**

- Reports scheduling settings are not preserved during upgrade.
- Under rare conditions reports list is not updated in the LabTech server. To resolve that update system cache via Tools option: “Reload System Cache”.

**Uninstall**

- Under rare conditions reports list, dataviews, monitors are not removed in the LabTech server after uninstall process. To resolve that, update system cache via Tools option: “Reload System Cache”.
Prerequisites

This section describes system requirements and factors that you need to consider before deploying the Veeam Backup & Replication Plug-in.

Virtualization Platforms

The Veeam Backup & Replication Plug-in supports the same virtualization platforms as Veeam Backup & Replication:

<table>
<thead>
<tr>
<th>VMware vSphere Environment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Platforms</strong></td>
</tr>
<tr>
<td><strong>Software</strong></td>
</tr>
<tr>
<td><strong>Hosts</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Microsoft Hyper-V Environment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Platforms</strong></td>
</tr>
<tr>
<td><strong>Software</strong></td>
</tr>
<tr>
<td><strong>Hosts</strong></td>
</tr>
</tbody>
</table>
System Requirements

To install and use the plug-in, make sure that your LabTech IT automation system meets the necessary system requirements.

LabTech Server

The machine where you want to install the Veeam Backup & Replication Plug-in must meet the following requirements:

<table>
<thead>
<tr>
<th>Specification</th>
<th>Requirements</th>
</tr>
</thead>
</table>
| LabTech RMM   | • LabTech 10.5  
                • LabTech 11  |
| OS            | Only 64-bit versions of the following operating systems are supported: |
|               | • Microsoft Windows Server 2012 R2  
                • Microsoft Windows Server 2012  
                • Microsoft Windows Server 2008 R2 SP1  
                • Microsoft Windows Server 2008 SP2  |
| Software      | • LabTech Server (for software and hardware requirements, refer to LabTech Installation Prerequisites).  
                • Microsoft .NET Framework 4 or later  
                • Microsoft PowerShell 2.0 or later  |

Note
Before you install Veeam Backup & Replication Plug-in, on the workstation with the LabTech Control Center, check whether the \L:\ drive is mapped to the LTShare on the LabTech server. If the drive is not mapped to the LTShare, Veeam reports will not be installed.

By default, the \L:\ drive is automatically mapped to the LTShare when the LabTech server is installed. If the drive is not mapped, you will need to map it manually.

Backup Manager Plug-in

The Veeam Backup & Replication Plug-in integrates with LabTech Backup Manager to help you quickly identify issues with backup and replication jobs.

For details on Backup Manager installation and configuration, refer to LabTech Backup Manager documentation.

Veeam Backup Servers

Every managed machine that runs Veeam Backup & Replication or Veeam Backup Enterprise Manager must have the following software installed:

• LabTech Agent  
• Microsoft PowerShell 2.0 or later  
• Veeam Backup & Replication 8.0 (Standard, Enterprise or Enterprise Plus Edition).  
• Veeam Backup & Replication 9.0 (Standard, Enterprise or Enterprise Plus Edition)
Virtual Machines

Every managed VMware and Hyper-V virtual machine must have LabTech Agent and either VMware Tools or Hyper-V integration services installed.

Note
For software and hardware requirements to machines running LabTech agents, refer to LabTech Agent Deployment Requirements.

Permissions

LabTech User Account

To access the Veeam Backup & Replication data in the LabTech Control Center, a user must have Read permissions for Templates, Clients, Reports and Scripts, Dataviews.

All Veeam Backup & Replication Plug-in objects, such as dashboards, reports, alerts and tickets, will be limited to the clients and groups to which the user has access.

LabTech Agent Account on Backup Server

To manage Veeam Backup & Replication jobs, the account under which a LabTech agent runs on a Veeam backup server must meet the following requirements:

- If Veeam Backup & Replication uses a local SQL Server to host its database, the account under which a LabTech agent runs must have sysadmin privileges.
- If Veeam Backup & Replication uses a remote SQL Server to host its database, the LabTech Monitoring Service account must have db_owner privileges on the Veeam backup database.
- The account must have the Veeam Backup Operators or Veeam Backup Administrators role assigned in Veeam Backup & Replication

Note
If the agent account does not have these privileges, you will not be able to start, end, enable and disable jobs on a remote Veeam backup server.

Licensing

The Veeam Backup & Replication Plug-in is supplied free of change and does not require any license.
Installing Veeam Backup & Replication Plug-in

To install and configure the Veeam Backup & Replication Plug-in:

1. Check prerequisites.
2. Deploy LabTech agents on VMs and Veeam backup servers.
3. Install the Veeam Backup & Replication Plug-in.

Before You Begin

Before you install the Veeam Backup & Replication Plug-in, make sure that your managed environment meets the necessary requirements. For details, see Prerequisites.

Step 1. Deploy LabTech Agents

Deploy LabTech agents on all machines designated as targets for monitoring and reporting with the LabTech IT automation system. You can monitor and manage the following types of machines:

- Veeam backup servers: physical or virtual machines running Veeam Backup & Replication and Veeam Backup Enterprise Manager
- VMware and Hyper-V VMs protected with Veeam Backup & Replication

For information on requirements to agent-enabled machines and deployment methods, see LabTech Agent Deployment Documentation.

Step 2. Install the Veeam Backup & Replication Plug-in

You can install the Veeam Backup & Replication Plug-in either from the LabTech Solution Center (recommended) or manually, in the LabTech Control Center.

To install the Veeam Backup & Replication Plug-in from the LabTech Solution Center:

1. Open the LabTech Control Center.
2. From the Control Center menu, choose Tools > Solution Center.
3. In the Solution Center, search for the Veeam Backup & Replication solution.
4. Click the Veeam Backup & Replication solution and click Queue.
5. In the Terms of Service window, click Yes.
6. Click Solutions Queue at the top of the navigation sidebar.
7. In the Queued Solutions section, click Install/Update.
8. In the Install/Update Notice window, choose whether you want to back up the local database before upgrade and click Yes.
9. After installation completes, click Finished and close the Solution Center.
10. From the Control Center menu, choose Help > Plugin Manager.
11. In the list of available plug-ins, select Veeam Backup & Replication Plug-in and click Enable.
12. Click Advanced, select Reload Plugins > Reload DBAgent Plugins. In the displayed dialog box, click Yes. Wait for LabTech to restart the database agent.
13. Restart the Control Center. The install process may take from one to several minutes to complete.
To install the Veeam Backup & Replication Plug-in manually:

1. Contact Veeam Support to obtain the Veeam Backup & Replication Plug-in version 1.1.1.
2. Open the LabTech Control Center.
3. From the Control Center menu, choose **Help > Plugin Manager**.
4. In the **Plugin Manager** window, click **Advanced**, select **Manage Plugins > Add Plugin** and choose the plug-in file `Veeam.LBP.dll` in the setup folder.
5. In the **Add a Plugin** window, click **Save and Close**.
6. In the list of available plug-ins, select the Veeam Backup & Replication Plug-in and click **Enable**.
7. Click **Advanced**, select **Reload Plugins > Reload DBAgent Plugins**. In the displayed dialog box, click **Yes**. Wait for LabTech to restart the database agent.
8. Restart the Control Center. The install process may take from one to several minutes to complete.

When installation completes, the Veeam Backup & Replication Plug-in will automatically perform its initial configuration:

- Discover Veeam Backup & Replication servers and add these servers to the *Veeam Backup* group
- Schedule a data collection script for the discovered backup servers
- Assign a set of monitors to the discovered backup servers
Upgrading the Veeam Backup & Replication Plug-in

Upgrade to the Veeam Backup & Replication Plug-in version 1.1.2 is supported from version 1.1.1 only. To upgrade from earlier versions, upgrade to version 1.1.1 first.

You can upgrade the Veeam Backup & Replication Plug-in either from the LabTech Solution Center (recommended) or manually, in the LabTech Control Center.

To upgrade the Veeam Backup & Replication Plug-in from the LabTech Solution Center:

1. Open the LabTech Control Center.
2. From the Control Center menu, choose Tools > Solution Center.
3. In the Solution Center, search for the Veeam Backup & Replication solution.
4. Click the Veeam Backup & Replication solution and click Queue.
5. In the Terms of Service window, click Yes.
6. Click Solutions Queue at the top of the navigation sidebar.
7. In the Queued Solutions section, click Install/Update.
8. In the Install/Update Notice window, choose whether you want to back up the local database before upgrade and click Yes.
9. After upgrade completes, click Finished and close the Solution Center.
10. From the Control Center menu, choose Help > Plugin Manager.
11. In the list of available plug-ins, select Veeam Backup & Replication Plug-in and click Enable.
12. Click Advanced, select Reload Plugins > Reload DBAgent Plugins. In the displayed dialog box, click Yes. Wait for LabTech to restart the database agent.
13. Restart the Control Center. The upgrade process may take from one to several minutes to complete.
14. After you restart the Control Center, clear the LabTech system cache. To do this, from the Control Center menu, choose Tools > Reload System Cache.

To upgrade the Veeam Backup & Replication Plug-in manually:

1. Contact Veeam Support to obtain the Veeam Backup & Replication Plug-in version 1.1.2.
2. Open the LabTech Control Center.
3. From the Control Center menu, choose Help > Plugin Manager.
4. In the list of available plug-ins, select Veeam Backup & Replication Plug-in.
5. Click Advanced, select Manage Plugins > Add Plugin and choose the plug-in file Veeam.LBP.dll in the setup folder.
6. In the Add a Plugin window, click Save and Close.
7. In the list of available plug-ins, select the Veeam Backup & Replication Plug-in and click Enable.
8. Click Advanced, select Reload Plugins > Reload DBAgent Plugins. In the displayed dialog box, click Yes. Wait for LabTech to restart the database agent.
9. Restart the Control Center. The upgrade process may take from one to several minutes to complete.
10. After you restart the Control Center, clear the LabTech system cache. To do this, from the Control Center menu, choose Tools > Reload System Cache.
Important! Upgrading the Veeam Backup & Replication Plug-in by means of the Update the Plugin function is not recommended. If you perform upgrade using the Update the Plugin function, all Veeam backup historical data in the LabTech database will be lost.

Uninstalling the Veeam Backup & Replication Plug-in

Uninstalling the Veeam Backup & Replication Plug-in removes from the LabTech Control Center all plug-in objects (machine group, dashboards, dataviews, reports, and so on), and removes from the LabTech database all historical data collected by the plug-in.

To uninstall the Veeam Backup & Replication Plug-in:

1. Open the LabTech Control Center.
2. On the Control Center toolbar, click Dashboard.
3. Alternatively, choose Main > Dashboard from the Control Center menu.
4. In the System Dashboard window, open Config > Integration > Veeam Backup & Replication.
5. In the menu on the left, click Uninstall.
6. Click the Uninstall button.
7. In the displayed dialog box, click Yes to confirm the uninstall operation.
8. The uninstall process may take several minutes to complete.
9. Restart the Control Center.

If the Veeam Backup & Replication Plug-in objects remain in the LabTech Control Center after uninstall, clear the LabTech Client cache. To do this, from the Control Center menu, choose Tools > Reload System Cache.
Contacting Veeam Software

At Veeam Software we value the feedback from our customers. It is important not only to help you quickly with your technical issues, but it is our mission to listen to your input, and build products that incorporate your suggestions.

Customer Support

Should you have a product issue, suggestion or question, please visit our Customer Center Portal at cp.veeam.com to open a case, search our knowledge base, reference documentation, manage your license or obtain the latest product release.

Online Support

If you have any questions about Veeam solutions, you can use the following resources:

- Full documentation set at www.veeam.com/documentation-guides-datasheets.html
- Community forum: forums.veeam.com

Company Contacts

For the most up to date information about company contacts and offices location, please visit www.veeam.com/contacts.html.