Unable to Connect Hyper-V Host via WMI. User credentials cannot be used for local connections.

KB ID:
1362
Product:
Veeam Backup & Replication
Version:
6.0.0.153
Published:
Last Modified:
2013-04-29

Challenge

When trying to add a Hyper-V host, you receive the error "Unable to connect via WMI. User Credentials cannot be used for local connections."

User-added image

Cause

Not all of the prerequisites have been installed when using Veeam Backup & Replication.  

Solution

Before adding Hyper-V servers, check the following prerequisites:

  1. Make sure the SCVMM Admin UI is installed on the Veeam Backup & Replication server. Otherwise, you will not be able to add SCVMM servers to Veeam Backup & Replication. 
  2. On every connected Hyper-V server, Veeam Backup & Replication deploys a set of components – Veeam Installer Service, Veeam Transport Service and Hyper-V Integration Service. Ensure that File and Printer Sharing is enabled in the network connection settings of the server; otherwise, the components will not be installed.

More Information

This only occurs in version 6 of Veeam Backup & Replication.  

Also, how to install the SCVMM Admin UI from Microsoft is available here:

http://technet.microsoft.com/en-us/library/bb740758.aspx

Please be aware that we’re making changes which will restrict access to product updates for users without an active contract.

OK

Rate the quality of this KB article: 
2.1 out of 5 based on 20 ratings

Couldn't find what you were looking for?

Below you can submit an idea for a new knowledge base article.

Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Spelling error in text:

Submit