Backups are removed from UI after manual rescan

KB ID: 2249
Product: Veeam Backup & Replication
Version: 9.5
Published: 2017-03-22
Last Modified: 2020-08-13
Get weekly article updates
By subscribing, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.

Cheers for trusting us with the spot in your mailbox!

Now you’re less likely to miss what’s been brewing in our knowledge base with this weekly digest

error icon

Oops! Something went wrong.

Please try again later.

Challenge

Backup files may disappear from UI and jobs may initiate active full backups after manual rescan of the repository. All repository types are affected, especially deduplicated appliances because they provide native replication between units.

User-added image

Cause

The issue is caused when the following conditions are met:
  1. Two different Veeam Backup Repositories are created under the same paths
  2. Backup job works with Veeam Backup Repository #1
  3. Additionally, backup files with the metadata file are copied manually, by script, or over third-party replication solutions to Veeam Backup Repository #2
  4. You have rescanned Veeam Backup Repository #2
  5. Backup files disappear from the UI (Backups -> Disk) and backup jobs begin performing active fulls

Solution

Please download the private fix below, and install it on Veeam B&R server: 
  1. Ensure all jobs are stopped
  2. Go to the Veeam Backup Server and verify you are running version 9.5.0.823. You can check it browsing to Option -> Help -> About 
  3. Stop all Veeam B&R services manually or use the following PowerShell query: Get-Service -DisplayName "Veeam*" | stop-service
  4. Please make a backup of the following *.dll files: Rename Veeam.Backup.Core.dll to the Veeam.Backup.Core.dll_original in the installation folder (default path C:\Program Files\Veeam\Backup and Replication\Backup)
  5. Afterwards copy the *.dll files from the archive
  6. Start all Veeam B&R services manually or using the following PowerShell query: Get-Service -DisplayName "Veeam*" | start-service

More information

Note: the hotfix only prevents the issue from reoccurring. Please contact Veeam Support to get your backup chain back into the UI and continue backup incrementally if the job has not generated any new active fulls yet.
Click here to send feedback regarding this KB, or suggest content for a new KB.
To report a typo on this page, highlight the typo with your mouse and press CTRL + Enter.

Spelling error in text

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

Oops! Something went wrong.

Please try again later.

KB Feedback/Suggestion

This form is only for KB Feedback/Suggestions, if you need help with the software open a support case

By submitting, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Verify your email to continue your product download
We've sent a verification code to:
  • Incorrect verification code. Please try again.
An email with a verification code was just sent to
Didn't receive the code? Click to resend in sec
Didn't receive the code? Click to resend
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

error icon

Oops! Something went wrong.

Please try again later.