Failed to start service VeeamDeploymentService on ServerCore installation

KB ID: 1819
Product: Veeam Backup & Replication
Version: 7.x, 8.x, 9.x
Published:
Last Modified: 2017-02-02

Challenge

Adding a Hyper-V core server to Veeam fails.  The following is present in logs:
 

[Timestamp] <92> Error    Failed to start service 'VeeamDeploymentService'. Host: ‘x.x.x.x’..
[Timestamp] <92> Error    Failed to start deployment service on the target host
[Timestamp] <92> Error    --tr:Failed to install service [VeeamDeploymentService] was not installed on the host [192.168.0.87].
[Timestamp] <57> Error    [192.168.0.87] Failed to install deployment service using IP ' x.x.x.x '. (System.Exception)
[Timestamp] <57> Error    The service did not respond to the start or control request in a timely fashion. 


OR:

[Timestamp] <01> Error    Failed to start service 'VeeamDeploySvc'. Host: 'X.X.X.X'.
[Timestamp] <01> Error    --tr:Error code: 0x00000002
[Timestamp] <01> Error    Failed to start deployment service on the target host
[Timestamp] <01> Error    --tr:Failed to install service [VeeamDeploySvc] was not installed on the host [X.X.X.X].

Cause

The ServerCore-WoW64 role is not installed on the Hyper-V host: http://msdn.microsoft.com/en-us/library/windows/desktop/dd371790(v=vs.85).aspx

Some Veeam services run as 32 bit processes. 

Solution

To resolve, install ServerCore-WoW64 role on Hyper-V host (requires reboot).

2 / 5 (8 votes cast)

Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Orphus system