"Length cannot be less than zero" error during the Update installation

KB ID: 2425
Product: Veeam ONE
Version: 7.x, 8.x, 9.x
Published:
Last Modified: 2018-01-04

Challenge

The Update for Veeam ONE fails during the installation with the error message "Length cannot be less than zero".

Cause

User Principal Name or UPN (user@domain) is currently unsupported with Veeam ONE. User Logon Name or ULN (domain\user) is the only supported username format for the product.

Solution

In order to solve the issue, amend the Veeam ONE Monitor and Veeam ONE Reporter service credentials prefix to Domain\Username format:

1. Open Services snap-in on the Veeam ONE server;
2. Find the Veeam ONE Monitor Server service and open the properties;
3. Navigate to the Log On tab;
4. Update the credentials prefix to Domain\Username format;
5. Restart the service to apply the changes;
6. Perform the same steps for Veeam ONE Reporter Server service;
7. Install the Update.
 

More Information

Should you have any questions, please contact Veeam Support.
How helpful is this article: 
5 out of 5 based on 2 ratings

Couldn't find what you were looking for?

Below you can submit an idea for a new knowledge base article.

Request new content

Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Orphus system