Configuration system failed to initialize

KB ID: 1199
Product: Veeam Backup & Replication | 5.0 | 6.1 | 6.5 | 7.0 | 8.0 | 9.0 | 9.5 | 10 | 11
Published: 2011-08-26
Last Modified: 2021-10-27
Get weekly article updates
By subscribing, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.

Cheers for trusting us with the spot in your mailbox!

Now you’re less likely to miss what’s been brewing in our knowledge base with this weekly digest

error icon

Oops! Something went wrong.

Please try again later.

Challenge

Veeam Backup & Replication 11/11a

When attempting to launch the Veeam Backup & Replication Console nothing happens. Within Task Manager, the process (veeam.backup.shell.exe) can be seen starting, then immediately terminating. Due to the cause of this issue, it may also be noticed that only a specific account has the issue.

Reviewing Application Events (eventvwr.msc) logs the following error is found:

Log Name:      Application
Source:        .NET Runtime
Event ID:      1026
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Application: veeam.backup.shell.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Configuration.ConfigurationErrorsException
   at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean)
   at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(System.Configuration.ConfigurationSchemaErrors)
   at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(System.Object, System.Configuration.Internal.InternalConfigEventArgs)

Veeam Backup & Replication 10a and older:

When attempting to launch the Veeam Backup & Replication Console, the Console fails to launch, and the following error is displayed:

Configuration system failed to initialize
Root element is missing.
(C:\Users\USER\AppData\Local\Veeam_Software\Veeam.Backup.Shell.exe_Url_hjcgiuywagefjhy872hnd\5.0.2.0\user.config)
Root element is missing

Cause

The user.config file found in the following path has become corrupt:
C:\Users\<user>\AppData\Local\Veeam_Software_Group_GmbH\veeam.backup.shell.exe_Url_<guid>\<version>

Solution

To resolve the error, delete the file in question (user.config) and relaunch the Veeam Backup Console. The file will be regenerated automatically.
Click here to send feedback regarding this KB, or suggest content for a new KB.
To report a typo on this page, highlight the typo with your mouse and press CTRL + Enter.

Spelling error in text

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

Oops! Something went wrong.

Please try again later.

KB Feedback/Suggestion

This form is only for KB Feedback/Suggestions, if you need help with the software open a support case

By submitting, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Verify your email to continue your product download
We've sent a verification code to:
  • Incorrect verification code. Please try again.
An email with a verification code was just sent to
Didn't receive the code? Click to resend in sec
Didn't receive the code? Click to resend
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

error icon

Oops! Something went wrong.

Please try again later.