Hardware encryption doesn't work on tape operations after update to 9.5 Patch 4b

KB ID: 2981
Product: Veeam Backup & Replication
Version: 9.5.4.2866
Published: 2019-07-18
Last Modified: 2020-08-13
Get weekly article updates
By subscribing, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.

Cheers for trusting us with the spot in your mailbox!

Now you’re less likely to miss what’s been brewing in our knowledge base with this weekly digest

error icon

Oops! Something went wrong.

Please try again later.

Challenge

After you update to patch 4b (9.5.4.2866), you may face the following encryption-related issues during the backup and restore procedures.
Restore from tape backups made in the previous product versions with enabled hardware encryption may fail with the following error message:
[11.07.2019 20:07:56] <  5652> mt |   Drive encryption status:
[11.07.2019 20:07:56] <  5652> mt |   Encryption Mode: Disabled
[11.07.2019 20:07:56] <  5652> mt |   Decryption Mode: Disabled
[11.07.2019 20:07:56] <  5652> mt |   Raw Decryption Mode Disabled (RDMD): Disabled
[11.07.2019 20:07:56] <  5652> mt |   Volume Contains Encrypted Logical Blocks (VCELB): Disabled
[11.07.2019 20:07:56] <  5652> mt |   Logical Block encryption parameters: Application Managed
[11.07.2019 20:07:56] <  5652> mt |   Hardware encryption is available
[11.07.2019 20:07:56] <  5652> mt | ERR | [MT]SCSI PASS THROUGH DIRECT ended with Scsi Error Fixed format, current;  Sense key: Illegal Request. Additional sense: Invalid field in command information unit
[11.07.2019 20:07:56] <  5652> mt | >>  |tr:Failed to enable hardware encryption, tapeHandle: 0x00000000000006a4
[11.07.2019 20:07:56] <  5652> mt | >>  |tr:Failed to create TapeReader.
[11.07.2019 20:07:56] <  5652> mt | >>  |tr:Failed to create TapeFileReader, setPba: 614675, localFla: 136589546, restFileSize: 4621392384
[11.07.2019 20:07:56] <  5652> mt | >>  |An exception was thrown from thread [5652].
Tape backups will finish without any visible errors. However, the tape job statistics may show that the software encryption was used instead of the hardware one.

This issue occurs under the following conditions:
 
  1. The tape library is hardware.
  2. Encryption is enabled in the target media pool settings (https://helpcenter.veeam.com/docs/backup/vsphere/add_media_pool_encryption.html?ver=95u4).
  3. In the tape library settings, the encryption is set to Application managed (this setting is configured on the vendor side).

Solution

To solve the issue, apply the hotfix:
  1. Download the hotfix.
  2. Check the current version of Veeam Backup & Replication. It must be 9.5.4.2866.
  3. Make sure that no jobs are running, close the console, and stop all Veeam services.
  4. Right-click on the installation file and click "Run as administrator"
  5. Go through the wizard to install private fix.
  6. Relaunch Veeam Backup Console and let Veeam automatically update hosts added to the Veeam server.

More information

DOWNLOAD PRIVATE FIX


MD5 for kb2981.zip: 567db99e79fb6bd95251deb769d90238
SHA-1 for kb2981.zip: 0c8ad6b3c0841402c8da1e05e1acbb7e0bfcadf8
Click here to send feedback regarding this KB, or suggest content for a new KB.
To report a typo on this page, highlight the typo with your mouse and press CTRL + Enter.

Spelling error in text

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

Oops! Something went wrong.

Please try again later.

KB Feedback/Suggestion

This form is only for KB Feedback/Suggestions, if you need help with the software open a support case

By submitting, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
Verify your email to continue your product download
We've sent a verification code to:
  • Incorrect verification code. Please try again.
An email with a verification code was just sent to
Didn't receive the code? Click to resend in sec
Didn't receive the code? Click to resend
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

error icon

Oops! Something went wrong.

Please try again later.