Installation Fails with Patched Database

KB ID: 1845
Products: Veeam Backup & Replication
Version: 6.5, 7.0, 8.x, 9.x
Published:
Last Modified: 2016-09-13

Challenge

When installing Veeam Backup & Replication, selecting an existing configuration database fails due to the following error message:
 

Unable to use database VeeamBackup, because it was created with a later version of Veeam Backup and Replication.
 
OR
 
The Configuration Database Connection Settings utility is unable to select a database due to the following error message:
 

Unable to use database VeeamBackup, because it was not created with current version of Veeam Backup and Replication.
 
In older versions of the software, or if the configuration database location is changed via the registry, no error message appears, but the Veeam Backup Service fails to start.

Cause

When Veeam Backup & Replication is updated, the configuration database is upgraded and its version number is changed. The updated database is not compatible with the Generally Available version of the software.
 
For example, Veeam Backup & Replication v9 GA (9.0.0.902) is upgraded to v9 Update 1 (9.0.0.1491), and then uninstalled. In this scenario, attempting to reinstall from the v9 ISO using the existing configuration database will fail. This is because the database version is greater than the latest version supported by the software.

Solution

Recommended Method:
 
If Veeam Backup & Replication is already installed, apply the latest update.
 
If it is not installed:

  1. Choose a new database name during installation. An empty database will be created with this name.
  2. Once installation has completed, apply the latest update.
  3. Switch from the empty database to the original configuration database using the Configuration Database Connection Settings utility.
 
To delete the empty database after installation, use SQL Server Management Studio.
  1. In Object Explorer, connect to the instance containing the empty database (such as localhost\VEEAMSQL2012).
  2. Expand Databases, right-click the empty database, and then click Delete.
  3. Confirm the correct database is selected, and then click OK.
 
 

Legacy Method:
 
The version number of the configuration database can be reverted with the following query:
 
Use VeeamBackup
UPDATE [Version] SET current_version = <see table below>
 
Build numbercurrent_version
6.5.0.109633
7.0.0.6901179
8.0.0.8171870
9.0.0.9022754
 
Once the version number is reverted, it is possible to install using the existing database. However, the software cannot be used in this configuration: it must immediately be updated to the same or later version that was previously installed. Otherwise, data corruption or unexpected behavior may occur.
 
Certain updates alter the database schema in a way that requires an additional change to the Version table before the update can be installed:
 
Updatecurrent_version
v7 Patch 4 (7.0.0.871)1200
v8 Update 3 (8.0.0.2084)2022

 
Do not attempt to revert to a previous release of the software (such as to v8 from v9).

More Information

How to apply a SQL script 
 
If there may be other problems with the configuration database, try restoring from configuration backup. It is recommended to create a configuration backup prior to updating the software.
 
ISOs containing updated versions of the software (maintenance releases) are not available. For more information on this topic, consult the Community Forum.


 
4 / 5 (15 votes cast)

Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Orphus system