Upgrade fails with “Unable to use database VeeamBackup, because it has an unsupported compatibility level (SQL Server 2008 or later is required)”

KB ID: 2206
Product: Veeam Backup & Replication
Version: 9.5
Published:
Last Modified: 2016-12-20

Challenge

When attempting to upgrade the Veeam Backup and Replication software, an error is encountered:

Unable to use database VeeamBackup, because it has an unsupported compatibility level (SQL Server 2008 or later is required)
 

Cause

Veeam Backup and Replication 9.5 no longer supports databases with a compatibility level of 2005 or lower.
 

Solution

Change the compatibility level of the database to 2008 or higher:

In SQL Server Management studio this can be done by following these steps:
  1. Right-click the database in question
  2. Click ‘properties’ 
  3. Click the ‘options’ tab 
  4. Drop down the ‘Compatibility Level’ box and change the compatibility level to 2008 or higher
User-added image

The following queries can be run to check the compatibility level and change it:

(Before running any queries, always back up the Veeam database (http://www.veeam.com/kb1471))
To check the compatibility level run:
 
SELECT compatibility_level 
FROM sys.databases WHERE name = 'Veeambackup';  

 
To change the compatibility level run***:
 
ALTER DATABASE Veeambackup
SET COMPATIBILITY_LEVEL = 100;

 
***‘100’ is the compatibility level for 2008. To change it to 2012, use ‘110’. To change it to 2014, use ‘120’. You cannot change the compatibility level to be high than the version of the SQL instance being used.
 

4 / 5 (12 votes cast)

Couldn't find what you were looking for?

Below you can submit an idea for a new knowledge base article.

Request new content

Report a typo on this page:

Please select a spelling error or a typo on this page with your mouse and press CTRL + Enter to report this mistake to us. Thank you!

Orphus system