#1 Global Leader in Data Protection & Ransomware Recovery

Invalid backup configuration: Team chats backup using protected APIs must the enabled to protect Team chats.

KB ID: 4403
Published: 2023-01-30
Last Modified: 2023-01-30
mailbox
Get weekly article updates
By subscribing, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.

Cheers for trusting us with the spot in your mailbox!

Now you’re less likely to miss what’s been brewing in our knowledge base with this weekly digest

error icon

Oops! Something went wrong.

Please, try again later.

Challenge

After upgrading Veeam Backup for Microsoft 365 from v5 to v6a, during the next backup run, or when editing the job or organization, the following error occurs:

Invalid backup configuration: Team chats backup using protected APIs must the enabled to protect Team chats.
Error

Issue Prevention

Veeam Backup for Microsoft 365 6.0 contains specific changes that will help avoid the issue covered by this article. For that reason, if you plan to leverage Graph API to protect Teams data, and you are on version 5 or lower, upgrade to Veeam Backup for Microsoft 365 6.0 first and then upgrade to 6a. After using that upgrade path, review KB4340: How To Configure Veeam Backup for Microsoft 365 to Use Microsoft Graph Export API for Teams.

 

Solution

HotFix Installation Instructions:

  1. Ensure you are running Veeam Backup for Microsoft 365 build 6.1.0.438 (P20221215)
  2. Ensure that there are no Backup jobs or Restore sessions running.
  3. On the Veeam Backup for Microsoft 365 server, stop the following services:
    • Veeam Backup for Microsoft 365
    • Veeam Backup Proxy for Microsoft 365
  4. Download the hotfix via the button below.
  5. Extract the fix to: C:\Temp\KB4403\
  6. After extraction, unblock the file using the following PowerShell cmdlet:
Get-ChildItem -Path "C:\Temp\KB4403\" -Recurse -Force | Unblock-File
  1. Back up the original files and replace them with the ones from the hotfix in the following locations:
    • C:\Program Files\Veeam\Backup365\Veeam.Archiver.Controller.dll
    • C:\Program Files\Veeam\Backup365\Veeam.Archiver.Proxy.Integration.dll
    • C:\Program Files\Veeam\Backup365\Veeam.Archiver.REST.exe
    • C:\Program Files\Veeam\Backup365\Packages\Proxy\Veeam.Archiver.Proxy.Integration.dll
  2. Start the services that were stopped in Step 3.
  3. Upgrade the Backup Proxy Servers.

Download Information

MD5: D914EAB5CE51246596B4B72D158B9A81
SHA-1: 7CB319E5D32ED45019245EE9132C82EE4A2CED56
To submit feedback regarding this article, please click this link: Send Article Feedback
To report a typo on this page, highlight the typo with your mouse and press CTRL + Enter.

Spelling error in text

This site is protected by hCaptcha and its Privacy Policy and Terms of Service apply except as noted in our Privacy Policy.
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

Oops! Something went wrong.

Please, try again later.

You have selected too large block!

Please try select less.

KB Feedback/Suggestion

This form is only for KB Feedback/Suggestions, if you need help with the software open a support case

By submitting, you are agreeing to have your personal information managed in accordance with the terms of Veeam's Privacy Notice.
This site is protected by hCaptcha and its Privacy Policy and Terms of Service apply except as noted in our Privacy Policy.
Verify your email to continue your product download
We've sent a verification code to:
  • Incorrect verification code. Please try again.
An email with a verification code was just sent to
Didn't receive the code? Click to resend in sec
Didn't receive the code? Click to resend
Thank you!

Thank you!

Your feedback has been received and will be reviewed.

error icon

Oops! Something went wrong.

Please, try again later.